Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 13, 2026 - 08:30 CST
Scheduled
I will take 1 hour to update the current game server in American Plains Mudding. It'll be quite fast and quick so it may take up to an hour or even less. This happens every week.
Posted Jun 10, 2026 - 08:37 CST
This scheduled maintenance affected: Game Server (United States, Europe, Middle East, Australia).